ERROR Message: Object reference not set to an instance of an object

Dear all,
I am encountering an error when loading a file created using 1.35 with the latest V 1.41. when I try to load the file I get the following error under Windows 10 and 11.

I have no problems when loading a 3D shell file, or when loading a smaller file.
Has anybody encountered the same issue

Well, PrePoMax grows so quickly that it’s often not possible to ensure backward compatibility. Try removing features from the model to see which one causes the error. You can also try opening the file e.g. in v1.4.0.

I really put a lot of work lately to ensure backward compatibility. Could you share the .pmx file for me to see if I can fix it?

You could try opening the file in v1.4.0 and if works save it. Then open it in version v1.4.1.

Dear all,
I discovered after trying to open other models that if I saved the .pmx file with the results of the calculation in the file, it does not open and gives the error reported. However, if the file just has the mesh and boundary conditions it opens.
I tried to send the files but the site indicates that the files cannot be larger than 8 MB. Any other option to send them. Matej I can send a link with the files so that you can download them.
Thanks for the attention given to my post. Thanks for a great application!
All the best!

You can just upload the files to some hosting website like WeTransfer, Dropbox or Google Drive and share the link here.

Here are the links to the files:

Let me know if you can open them and get the same error.
Best regards,

You have to set “Anyone with the link” in access settings first.

Here are the links again:

Best regards,
F Lorenzo

Where you guys able to open the two files that I sent?

Yes, now they can be downloaded.

Were you able to figure out what the issue is?

I can confirm that there is an error reading the file containing the results. I will fix the v1.4.1 version to be able to open the file but the results will probably be lost.

The problem is that I cannot open the file in any previous PrePoMax version. You said it is an old v1.3.5 model but opening it in the v1.3.5 version gives me the info that the file was last saved in the v1.4.0 version (bottom of the image):

Opening it in release version v1.4.0 does not work. Did you use any of the developer versions?

Matej, thank you for your comments and help.

I used 1.41dev for some time and 1.40dev.

What is strange is that trying to open a 3D shells pmx problem that contains the results is not a problem.
If the file does not have the results in it, it will open.
If the file is small and has results, 1.41 will open it.
It is with those files that have the results saved but are large > 50 MB that it results in the error.

Once again, Thanks Matej!

Dear Matej,
I was checking the files that I have created and found something that may shed some light into what the issue could be.
For the cases that give the error if you look in the files attached (if you can) the file does not have an imported geometry. I had some issues creating the mesh with Prepomax and tried using FreeCad or Netgen directly, and exported the mesh in .inp format, and opened it with Prepomax. did everything else to define materials, loading and boundary conditions and ran the file. Then I saved the solution.
I tired them again today and I can open with 1.41 cases regardless of size if I have a geometry in the file.
I do not know if this is the issue but it is what I discovered today.
Thanks Matej!

I can not figure out what really happened with your files. I prepared an updated version of the v1.4.1 release that can open the file you shared with the results, but the results are lost.

Can you test the new version on other files you had problems with?

I will give it a try and let you know. If I can get the files to open again, rerunning the file is the lesser of my problems.
Thank you very much for your help!
All the best
Fernando Lorenzo

It worked well!
Thanks Matej!

Grat, I am closing this topic.