Error in checktemp

I am using PrePoMax v1.4.0. Recently, every time I assign a temperature as an Initial Condition, when I run the analysis no results are given, and I get the error:

*ERROR in checktemp: no final temperature
defined in node XXXX

Sometimes the node number (XXXX) given is an existing node, but usually it is a node number higher than the maximum node number in the .inp file.

In the past, this functionality has worked fine.

I have attached a simple example that gives me this error.

Block.pmx (1.6 MB)

1 Like

It’s not a PrePoMax bug so I moved it to the General Questions section. The error comes from CalculiX. It will work if you add temperature also as a defined field.


Thank you FEAnalyst. This resolved the issue.

Do you mean like this?
I am trying to analyze a bolted joint and am running into the same error. I have a static step to preload the joint and an Uncoupled temperature-displacement step. if I make both steps as temperature displacement the error goes away. So I wanted to clarify what you mean with adding the temperature filed… adding it as an output or selecting a step that includes temperature? something else?

No, I wasn’t talking about temperature output. What I mean is defined field:

defined field 2

What!?? How did I miss that menu? I’m going blind.